To jest tylko wersja do druku, aby zobaczyć pełną wersję tematu, kliknij TUTAJ
My Navia
Windows CE - forum użytkowników nawigacji GPS

iGO, Primo Android - iGO_Luna mi nie działa - czyli watek o problemach

am531 - 2020-11-14, 19:19

Witam w końcu udało się uruchomić iGO Luna na HUAWEJ 5.1 po lekturze w tym wątku i zainstalowaniu
Vocalizer_V_3.1.7_Full.apk odpaliła od razu dziękuję wszystkim kolegom za włożony trud tu na forum jeszcze raz dziękuję
Kod:

adrusek - 2020-11-20, 23:04

Igo lune tak samo się dzieli na pamięć wew, zew i dopisując w sys jak nexgeinie czy jakoś inaczej?
dix62 - 2020-11-21, 08:36

adrusek napisał/a:
Igo lune tak samo się dzieli na pamięć wew, zew i dopisując w sys jak nexgeinie czy jakoś inaczej?
Prawie tak samo
Kod:
 android_secondary_root_path "/storage/5218-3142/Luna

no_taki - 2020-11-21, 15:04

A nawet dokładnie tak samo :-)
Tak w jak w nextgenach ,nazwa katalogu na karcie, w którym masz wydzieloną część content jest bez znaczenia.
Może byc to "Luna"" , może być i "Wojtek_łod_łorganisty" :-P i wszystko zadziała jeśli ścieżka w
Kod:
adroid_secondary_root_path =
będzie poprawnie prowadziła do tego folderu.

czyli jesli nasza karta jest rozpoznawana jako 1234-5678 , a wydzelona część content jest w folderze " Wojtek... to wywolanie ściezki
Kod:
 android_secondary_root_path "/storage/1234-5678/Wojtek_łod_łorganisty"
spowoduje, ze program bedzie widział mapy.

Jeśli masz o np Gifta i Lunę - możesz na karcie mieć dwa katalogi jeden dla Gifta o nazwie np. Addons, drugi do Luny o nazwie np. Luna.

Możesz tez mieć jeden WSPÓLNY katalog ( pomijając wygodę takiego rozwiązania ) na karcie dla obu programów, bowiem Luna przechowuje mapy w folderach o innych nazwach niż nextgen

Wtedy zawartośc takiego folderu wyglądałaby tak:


grojan - 2020-11-21, 17:09

No prawie... Folder buildid powinien się nazywać building
no_taki - 2020-11-21, 18:12

wiadomo. Robilem to na szybko.
eref - 2020-11-30, 12:49

Przeniosłem na kartę te dwa foldery, dodałem wpis do sys.txt, w sumie taki sam jak mam przy Nexgen. No i nie działa, uruchamia się i za chwilę wychodzi bez komunikatu o błędzie. W pamięci wewnętrznej działa ok. Nexgen podzielony też działa.
Dla Luny na karcie utworzyłem folder LUNA i tam przeniosłem te dwa katalogi: mg i !viscontent.
Wpis w sys.txt mam
android_secondary_root_path="/storage/9C33-6BBD/Luna"
Folder Save skasowany, program odinstalowany, wyczyszczone dane, retart telefonu, ponowna instalacja, tym razem z pliku iGO_Luna_9.35.2.153810_SD.apk, dalej to sama, uruchamia się i zaraz wychodzi.
Gdzie mam zrobiony błąd?

inek1 - 2020-11-30, 12:57

Myślę, że możesz przenieś tylko mg.
eref - 2020-11-30, 13:11

Z samym mg na karcie też to sama. Zauważyłem, że po uruchomieniu i zaraz po wyłączeniu się program sam w pamięci wewnętrznej tworzy pusty katalog mg. Może mam złą instalkę i te obie, pobrane z tego forum są tylko dla pamięci wew?
Instalki mam te, obie próbowałem
iGO_Luna_9.35.2.153810_SMS_ExtApp.apk
iGO_Luna_9.35.2.153810_SD.apk

szwagier22 - 2020-11-30, 13:22

inek1 napisał/a:
Myślę, że możesz przenieś tylko mg.

Cały content przeniosłem na dla testu na kartę i Luna działa bez problemu.
A w sys.txt tylko wpis
[folders]
content="/mnt/media_rw/0000-0000/content"
Fakt że telefon zrootowany, ale to kwestia wpisu w sys.txt. ;-)
Obydwie instalki są dobre, ta druga jak sama nazwa wskazuje służy do instalacji na SD, ale wtedy instaluje się ją inaczej.
Widocznie u ciebie program nie widzi tego co przeniosłeś na kartę.

eref - 2020-11-30, 13:45

szwagier22 napisał/a:
inek1 napisał/a:
Myślę, że możesz przenieś tylko mg.

Cały content przeniosłem na dla testu na kartę i Luna działa bez problemu.
A w sys.txt tylko wpis
[folders]
content="/mnt/media_rw/0000-0000/content"
.


No i ten wpis działa, dzięki. Przeniosłem cały folder, dałem ten wpis, oczywiście zmieniony pod swoją kartę i działa. Znowu mam parę GB więcej wolnej pamięci wew. bo po dograniu kilku map naszych sąsiadów program w pamięci za bardzo się rozrósł.
A no i nie mam telefonu zrotowanego, ale działa teraz jak chciałem.

szwagier22 - 2020-11-30, 13:58

eref napisał/a:
A no i nie mam telefonu zrotowanego, ale działa teraz jak chciałem.

No nie tak za bardzo, ponieważ nic nie zapiszesz w tym folderze na karcie - np nie dodasz fotoradaru. :mrgreen:
Dlatego zrób sobie katalog content w Lunie w pamięci i najlepiej przenieś do niego speedcam, lang i voice.
To niewielkie katalogi a program powinien korzystać z obydwu content i będzie możliwość zapisu. ;-)

eref - 2020-11-30, 14:22

Ok, zrobiłem tak jak piszesz no i znowu przy ładowaniu program się wyłącza. Przeniosłem znowu je na kartę pamięci i działa.
Na próbę dodałem na mapie fotoradar i po ponownym uruchomieniu programu jest na mapie dalej.
Może ma dostęp do zapisu na karcie pamięci?

szwagier22 - 2020-11-30, 14:46

eref napisał/a:
Może ma dostęp do zapisu na karcie pamięci?

A nie utworzył sobie katalogu w pamięci?

eref - 2020-11-30, 15:20

Też tak pomyślałem, ale sprawdziłem i nie tworzy katalogu content, przynajmniej w pamięci wewnętrznej w katalogu IGO_Luna.


Powered by phpBB modified by Przemo © 2003 phpBB Group