To jest tylko wersja do druku, aby zobaczyć pełną wersję tematu, kliknij TUTAJ
My Navia
Windows CE - forum użytkowników nawigacji GPS

PULPIT ClubManiaca - Wskaźnik poziomu baterii

zbyshek - 2012-02-29, 20:14

Marek_aa napisał/a:
atym napisał/a:
Jeśli chodzi o dźwięk,

...i mrugaaaaa! :lol:


No proszę i nowy pomysł - dobry - mrugający rezydentny sygnał optyczny (MRSO).

Brawo Marek_aa...
Ale żarty na bok...

Inne narzędzie ResInfo pokazuje wartość procentową - w oknie i na pasku



MioPocket 4





Trochę to wszystko chaotyczne...
Ale może komuś coś uda się wykombinować.
..

[ Dodano: 2012-03-03, 00:52 ]
imar42 napisał/a:

Coś podobnego było już kiedyś "produkowane" - jak tylko znajdę - dokleję tutaj...


Czy to chodzi o to (niestety linki padły):

http://www.my-navia.pl/vi...p=259280#259280

imar42 - 2012-03-04, 18:15

wioleta1817 napisał/a:
Czy to chodzi o to (niestety linki padły): http://www.my-navia.pl/vi...p=259280#259280
Tak - właśnie o to chodziło. Już wcześniej podałem linka do tego tematu.
:arrow: http://www.my-navia.pl/vi...p=347460#347460
Mam przygotowaną sprawdzoną już wersję z pojawiającym się obrazkiem. Niestety mam to na innym kompie i dopiero we wtorek mogę to "opublikować"
Link jest dobry i aktywny, bo to właśnie stamtąd pobrałem oryginalną wersją - i ta właśnie została poddana moim przeróbkom. Mam wrażenie, że kolega mirko1 odświeżył link i gdzieś o tym napisał (jeśli tak było, to nie pamiętam gdzie, a szukać nie mam czasu)

zbyshek - 2012-03-04, 21:37

Ano właśnie, przyznaje się, pisałem do mirko1.

Odświeżył link do swojej zmodyfikowanej wersji skryptu Dzakusa
- usunięte okienko informacyjne po uruchomieniu skryptu.
Ale działa super. Ja zmieniłem wav-y.

Na moje propozycje dodanie oprócz sygnału dźwiękowego dodatkowo symbolu (obrazka) odp. do stanu baterii mirko1 - uznał, że może być zbędny.
Cytat:
...ale jakiś mały symbol + dźwięk na 1 sek. Jak nie usłyszę, to zobaczę...
imar42, zapodaj ten skrypt z pojawiającym się obrazkiem :mrgreen:
Przy okazji: jak uruchomić ten skrypt wraz uruchamianiem panelu?

imar42 - 2012-03-05, 07:46

wioleta1817 napisał/a:
Zapodaj imar42 ten skrypt z pojawiającym się obrazkiem
Jak napisałem wcześniej - dopiero jutro.
wioleta1817 napisał/a:
jak uruchomić ten skrypt wraz uruchamianiem panelu?
Podaj nazwę i link do Twojego panelu - jutro postaram się również i tę sprawę naświetlić.
Marek_aa - 2012-03-05, 08:00

Tutaj wstawiam fragment skryptu startowego z panela _RUSer_a, skrypt ma za zadanie aktywować systemowy alarm niskiego poziomu baterii. Po odpowiednich przeróbkach także powinien rozwiązać w/w problem.


Kod:
While (True)
 If (BatteryPercentage() > 10 OR ExternalPowered())
 Else
 Run ("\ResidentFlash2\App\BatAlarm.exe","_L~Y!G_A0P1P2_*X")
 Sleep (4000)
 Kill ("BatAlarm.exe")
 Endif
 Sleep (25000)
EndWhile

imar42 - 2012-03-05, 11:22

Marek_aa, Podaj mi proszę link do tego panelu. Sprawdzę całość, bo w tym wycinku wiele rzeczy mi nie pasuje, lub przynajmniej jest niepełna...
Marek_aa - 2012-03-05, 17:06

imar42 napisał/a:
[b] Podaj link do tego panelu. Sprawdzę całość,


Proszę :
http://chomikuj.pl/malbor...0x480+for+SDMMC

Dodam że skrypt ten mam zainstalowany wraz z tym panelem na swojej navi. Poniżej umieszczam do wglądu cały skrypt, jest także do pobrania pod w/w linkiem.

Kod:
ShowWaitCursor
Kill("ScrollShell.exe")
Kill("YFLoader6.exe")
Kill("YFLoadRD.exe")
Kill("YFLoader.exe")
Kill("TaskManagerCE.exe")
Kill("DelaySelect.exe")
Kill("PhoneLink.exe")
Kill("main.exe")
Kill("ANWDOG.exe")
Kill("launch.exe")
HideWaitCursor
XCopy( SystemPath("ScriptPath")\"CopyToWindows\*.*", "\Windows",true,true )
XCopy( SystemPath("ScriptPath")\"CopyToDesktop\*.*", "\Windows\Desktop",true,true )
XCopy( SystemPath("ScriptPath")\"CopyToPrograms\*.*", "\Windows\Programs",true,true )
Run("\Windows\explorer.exe")
Minimize( explorer.exe )
Sleep(1000)
Run("\SDMMC\_iPhoneBoot_\_RUN_\Run.exe")
Minimize( explorer.exe )
Show( Run.exe )
HideWaitCursor
RunWait("\SDMMC\_iPhoneBoot_\_SCRIPTS_\_TaskbarShow.exe")
#Show( iPhoneToday.exe )
Kill("Run.exe")
Run("\SDMMC\_iPhoneBoot_\_SCRIPTS_\_TaskbarShow.exe")
Run("\SDMMC\_iPhoneBoot_\iPhoneToday.exe")
While (True)
 If (BatteryPercentage() > 10 OR ExternalPowered())
 Else
 Run ("\ResidentFlash2\App\BatAlarm.exe","_L~Y!G_A0P1P2_*X")
 Sleep (4000)
 Kill ("BatAlarm.exe")
 Endif
 Sleep (25000)
EndWhile

atym - 2012-03-05, 17:51

Marek_aa, przerobiłem sobie ten panel od Ciebie na 480x272 na swojego Modecom'a i wszystko śmiga.
I teraz mam pytanie... Czy ten skrypt zadziała, skoro nie mam takiej ścieszki dostępu do BatAlarm.exe (w całej navi też nie mogę znaleźć) ?
Przypuszczam, że w modelu Modecom jest podobna aplikacja zaszyta w oprogramowaniu, i że nic (chyba) nie idzie zrobić.

Marek_aa - 2012-03-05, 19:46

atym napisał/a:
Czy ten skrypt zadziała, skoro nie mam takiej ścieszki dostępu do BatAlarm.exe


No jak może zadziałać, skoro nie masz BatAlarm.exe.
Skrypt ten zapodałem jako działającą (sprawdzoną) pętle, która to kontroluje poziom naładowania baterii i w zależności od tego (w tej chwili 10%) uruchamia aplikacje.
Chodzi o to aby poeksperymentować i spróbować podstawić w linii :
Run ("\ResidentFlash2\App\BatAlarm.exe","_L~Y!G_A0P1P2_*X") - odegranie wava lub uruchomienie jakiejś innej adekwatnej aplikacji.
Skrypt ten w obecnej postaci jest w pełni kompatybilny z nawigacjami z procesorem MTK, które to mają właśnie w kat. ResidentFlash2\App\ plik o nazwie BatAlarm. Aplikacja ta otwiera na ekranie grafikę rozładowanej baterii i generuje dźwięk.
Po „kilowaniu” oryginalnego menu aplikacja ta także przestawała działać, a skrypt ten wskrzesza ją ponownie.

atym - 2012-03-05, 21:30

Ok... teraz to wszystko rozumiem... :->
Po eksperymentach dam znać.

imar42 - 2012-03-06, 14:02

Wrzucam obiecany komplet przerobionego skryptu z dodaną opcją pojawiającego się obrazka informującego o słabej baterii.
:arrow: http://chomikuj.pl/imar42...,1489061623.rar
Wszystko działa tak jak w poprzedniej wersji - dodatkowo wraz z komunikatem dźwiękowym pojawia się obrazek. Wyświetlany jest przez 10 sekund, ale poprzez dwuklik na nim można go wyłączyć natychmiast.

Miłej zabawy ;-)

atym - 2012-03-06, 14:09

Sprawdzę jak bateria będzie słabsza. (teraz mam full) ;-)
zbyshek - 2012-03-06, 23:47

Dla mnie super... tylko jeszcze ten autostart.

Mój panel - http://www.my-navia.pl/vi...p=295602#295602

Dzięki.
..

atym - 2012-03-08, 11:45

imar42 napisał/a:

Miłej zabawy ;-)

Pobawiłem się, niestety znowu wywala mi błąd:
Kod:
'EndWhole' without 'While'
Line 175 (.....ściaszka do scryptu..)
EndWhile

Pewnie jeszcze nie jest pod WinCE6 :-(

imar42 - 2012-03-08, 13:32

atym napisał/a:
Pewnie jeszcze nie jest pod WinCE6
Tak - sprawdziłem na swoim WayteQ z WinCE6 i miałem ten sam komunikat. Zajmę się tym na pewno w bliżej nieokreślonej przyszłości.


Powered by phpBB modified by Przemo © 2003 phpBB Group