To jest tylko wersja do druku, aby zobaczyć pełną wersję tematu, kliknij TUTAJ
My Navia
Windows CE - forum użytkowników nawigacji GPS

PULPIT ClubManiaca - Modyfikacje paneli - pozycja, wygląd, przypisanie ikon

Rysiek24 - 2008-12-14, 14:02

zmienilem w pliku ini z katalogu program files/ system/apps /navi_ice.ini edytowalem go i zrobilem prawidlowy dostep do pliku odpalajacego automape z karty SD i nadal nie moge uruchomic go z poziomu pulpitu.
ELM0 - 2008-12-14, 20:56

Rysiek24 napisał/a:
zmienilem w pliku ini z katalogu program files/ system/apps /navi_ice.ini edytowalem go i zrobilem prawidlowy dostep do pliku odpalajacego automape z karty SD i nadal nie moge uruchomic go z poziomu pulpitu.


podaj mi dokladna sciezke i nazwy oraz załączplik navi. Postaram się Ci to zrobić. Napisz jaki bład albo informacja Ci sie pojawia

Rysiek24 - 2008-12-14, 21:13

juz dziala, nie mam pojecia gdzie byl problem , zmienilem nazwe katalogu automapy na dokaldnie taka jak w pliku ini , a pliku ini zmienilem tylko z flash disk na storage card.

podobna operacje zrobilem z igo8 i jest ok , tu nie bylo problemow

kmy - 2008-12-16, 08:31
Temat postu: Dotakowe ikony na pulpicie Navia
Po uruchomieniu NaviII pojawia sie pulpit z napisem Navia i przyciskiem Navigacja
ale można dołożyć kolejne przyciski, w ten sposób robiąc własny pulpit z przyciskami do AM i MM, Playera bez konieczności odblokowywania Win.
Wpis w pliku menu.ini wygląda tak:
[320x240_background]
background = "Navia2008-SplashScreen.bmp"

[320x240_btn1]
btn_on = "Navia2008-NawigacjaON.bmp"
btn_off = "Navia2008-NawigacjaOFF.bmp"
btn_x = 93
btn_y = 200

btn_exe = "\flash_storage\MapaMap30\mapamap3.exe"
btn_on_click_close = 0

zmieniłem na:
[320x240_background]
background = "Navia2008-SplashScreen.bmp"

[320x240_btn1]
btn_on = "Navia2008-NawigacjaON.bmp"
btn_off = "Navia2008-NawigacjaOFF.bmp"
btn_x = 33
btn_y = 180

btn_exe = "\flash_storage\MapaMap30\mapamap3.exe"
btn_on_click_close = 0

[320x240_btn2]
btn_on = "Navia2008-AutoMapaON.bmp"
btn_off = "Navia2008-AutoMapaOFF.bmp"
btn_x = 174
btn_y = 180

btn_exe = "\flash_storage\MapaMap30\mapamap3.exe"
btn_on_click_close = 0

no i są dwa klawisze które są aktywne (narazie podpięta jest MM pod oba, bo nic więcej nie mam wgrane)
jest tylko jeden problem, ikony muszą być typu bmp z 16 bitowa głębią kolorów, a mój Corel może zapisać albo z 8 albo z 24 bitową głębią. 8 bitowe rozmazuje, 24 bitowe pokazuje jako czarne, jak w skrótach podam do obu klawiszy oryginalne ikony, to oba pokazują to samo poprawnie.

czy może ktoś mi napisać jak stworzyć ikony 16 bitowe bmp? Lub utworzyć i podesłać.

w załączeniu oryginalny katalog Navia z NaviaII

[ Dodano: 2008-12-16, 09:22 ]
a wygląda to tak:

jacekp1313 - 2008-12-16, 10:44
Temat postu: 16-bit
Chyba o to chodziło
kmy - 2008-12-16, 12:47

jacekp1313 napisał/a:
Chyba o to chodziło


w załączniku są oryginalne ikony Nawigacja, te ikony to mam (pierwsza rzecz to kopia zapasowa całości), ale dorobiłem sobie nowe ikony w Corelu, i wstawiłem zamiast oryginałów (tu akurat do AM) i te nowe ikony są zamazane. Corel tworzy bitmapę albo 8 albo 24 bitową, a program menu.exe z navi wyświetla tylko 16 bitowe.

Hukkle - 2008-12-16, 17:15

kmy napisał/a:
czy może ktoś mi napisać jak stworzyć ikony 16 bitowe bmp?

Będzie ci ciężko. Ja do tego celu używam Painta i ...windowsa95 z 1MB kartą graficzną. 65tys. kolorów to jest max jego możliwości. ;-)

kmy - 2008-12-16, 18:06

Hukkle napisał/a:
Będzie ci ciężko.


w zasadzie to już nie wazne, pracuj eteraz nad Panelem Night Car uruchamianym bez odblokowania windy, jak narazie jest sukces, uruchamia się, działaja multimedia i inne programy z podpiete pod Panel łacznie z TC i Playerami no i oczywiście z nawigacjami

teraz porządkuje pliki ini

także zaniechałem zmian w menu Navi,

Panel będzie równolegle wgrany na flash_storage i jedyna zmiana będzie wpis do autorun.inf.

Także temat tytułowy nie aktualny

ADom78 - 2008-12-16, 23:56

IrfanView jest darmowy a 16 bitowe bmp robi bez problemu. Wydłub sobie obrazek w czym chcesz nawet w CÓRwELU :oops: a puźniej otwórz w IrVi zapisz jako
duchu - 2008-12-17, 10:09
Temat postu: przerobienie skrótów w nowym panelu mio 200
Mam taka sytuację że ze skrótów nie wchodzi mi mapa ale jak wejdę przez TM to bez problemu wejdę
W pliku navi_Ice
mam coś takiego

ICONXPBUTTON
x = 16
y = 97
Command = \My Flash Disk\AutoMapa\wceAm.exe
SizeNormal = 48
SizePushed = 48
ScaleAlpha = 100
IconNormal = ..\Icons\am.ico
ScaleAlpha = 100
IconPushed = ..\Icons\am.ico


TEXT
x = 10
y = 145
Text = AutoMapa
Color = FFFFFF
FrameColor = 000000
Size = 15
Weight = 700
CreateFont
CreateFont

ICONXPBUTTON
x = -1
y = 83
Command = My Flash Disk\Program Files\MioMap\MioMap.exe
SizeNormal = 80
SizePushed = 80
ScaleAlpha = 100
IconNormal = ..\Icons\miomap.ico
ScaleAlpha = 100
IconPushed = ..\Icons\miomap-on.ico

na mio mampie i auto mapie mam napisane że ścieszka się zaczyna w My Flash Disk a mio napa jest na nawigacji a auto mapa na karcie i to może jest wina i dlatego nie odpala mi z tego skrótu na co mam zmienić by ścieżka się zgadzała
Mam pytanie jeszcze czy w ścieżce powinno być jako plik wykonawczy wceAm.exe czy automapa.exe z tego i tego odpalę ją??

ELM0 - 2008-12-17, 14:28

jeśli masz na karcie AutoMape to musisz zamienić My Flash Disk na storage card. powinno wtedy zadziałać ( należy podać dokładną ścieżke do pliku wykonawczego Auto Mapy wceam)


daj znać czy poszło

Rysiek24 - 2008-12-17, 22:14

i radze nazwac katalog dokladnie jak w skrocie , umnie byl wlasnie problem z tym i tez nie odpalalo nawet po przekierowaniui na karte pamieci
krzys44 - 2008-12-28, 00:13
Temat postu: Mio200
Mam odblokowany panel wgrane mapy MIOMAP 2008,IGO 8,AUTOMAPA i problem .Nie odpalaja sie żadne mapy.Dopiero z Tools,Explorer,storage kard...chcialbym uruchamiac z panelu.Pomocy.DZIĘKUJE GG 1620868 jak by ktoś.....
ELM0 - 2008-12-28, 11:03
Temat postu: Re: Mio200
krzys44 napisał/a:
Mam odblokowany panel wgrane mapy MIOMAP 2008,IGO 8,AUTOMAPA i problem .Nie odpalaja sie żadne mapy.Dopiero z Tools,Explorer,storage kard...chcialbym uruchamiac z panelu.Pomocy.DZIĘKUJE GG 1620868 jak by ktoś.....


jakim panelem masz odblokowane mio??

wtedy możemy pogadać/.

Trzeba pozmieniać ściezki dostepu do plików map.

krzys44 - 2008-12-28, 12:46
Temat postu: Re: Mio200
krzys44 napisał/a:
Mam odblokowany panel wgrane mapy MIOMAP 2008,IGO 8,AUTOMAPA i problem .Nie odpalaja sie żadne mapy.Dopiero z Tools,Explorer,storage kard...chcialbym uruchamiac z panelu.Pomocy.DZIĘKUJE GG 1620868 jak by ktoś.....



Powered by phpBB modified by Przemo © 2003 phpBB Group